Class HTTPHeaders
java.lang.Object
org.gcube.informationsystem.resourceregistry.api.rest.httputils.HTTPHeaders
Canonical HTTP header names shared by Resource Registry clients and server.
- Author:
- Luca Frosini (ISTI - CNR)
-
Field Summary
FieldsModifier and TypeFieldDescriptionstatic final StringStandard HTTP Content-Location response header name (RFC 9110 Section 8.7).static final StringStandard HTTP Link response header name (RFC 8288).static final StringStandard HTTP Prefer request header name (RFC 7240).static final StringStandard HTTP Preference-Applied response header name (RFC 7240).static final StringHTTP method override request header name.static final StringCustom HTTP header name communicating the current resolved context path when token resolution falls back to a previous path (emitted alongsideX-Result-Scope: previous-path).static final StringCustom HTTP header name communicating the operational scope of a successful response (e.g.static final StringCustom HTTP Warning header name for query parameter and content validation. -
Method Summary
-
Field Details
-
LINK
Standard HTTP Link response header name (RFC 8288).- See Also:
-
CONTENT_LOCATION
Standard HTTP Content-Location response header name (RFC 9110 Section 8.7). Carries the canonical URI of the returned payload on a successful creation/update response, or the URI that generated a failure on an error response.- See Also:
-
PREFER
Standard HTTP Prefer request header name (RFC 7240).- See Also:
-
PREFERENCE_APPLIED
Standard HTTP Preference-Applied response header name (RFC 7240).- See Also:
-
X_WARNING
Custom HTTP Warning header name for query parameter and content validation.- See Also:
-
X_RESULT_SCOPE
Custom HTTP header name communicating the operational scope of a successful response (e.g.hierarchical,state-filtered,previous-path), emitted as a single comma-separated value. Seeappendix/09-result-scope-conventions.mdin the reference documentation for the full normative contract.- See Also:
-
X_RESOLVED_CONTEXT_PATH
Custom HTTP header name communicating the current resolved context path when token resolution falls back to a previous path (emitted alongsideX-Result-Scope: previous-path).- See Also:
-
X_HTTP_METHOD_OVERRIDE
HTTP method override request header name. APOSTrequest carryingX-HTTP-Method-Override: QUERYis treated as a nativeQUERY(RFC 10008) request, for network intermediaries or client libraries that cannot send theQUERYmethod directly.- See Also:
-